1. biblScope typically expresses a range which is why the unit names
are given in the plural (mostly) : where in the singular it's because
we're typically talking about a large unit (vol, part) where only one is
likely to be named. It seems odd to say <biblScope type="vols" from="3"
2. renaming @type to @unit is not a bad idea, but since @type isn't
actually wrong -- it is the type of bibliographic scope being defined --
a scope defined in pages (or columns, if you insist) -- I'm loath to
introduce such a change with all the consequent backwards compatibility
3. the description could certainly be improved. How about the following
"identifies the units in terms of which the scope is defined, for
example <val>pp</val> for pages, <val>ll</val> for lines etc."
4. The list is not a closed one, so we don't actually need to add
col(umn)s but I am happy to do so if the people so wish.
Syd Bauman wrote:
> Good point. But actually, it's worse than you think (or at least,
> than you mention). The source ODD reads
> <desc>identifies the type of information conveyed by the
> element, e.g. <val>columns</val>, <val>pages</val>,
> implying that "pages" is a possible value of type=, not the thing to
> which the value refers. This is problematic, as now the Guidelines
> are suggesting two different values for the concept "pages" (because
> the actual suggested value for pages is 'pp').
> So at the very least, either the <val> phrase-level elements should
> be removed from the <desc>, or they should be brought in line with
> the suggested value list. (And in either case, the concept of
> "columns" should probably be present.)
> But furthermore, the suggested value list is inexplicably
> inconsistent with respect to number: some glosses of suggested values
> indicate singular, some plural.
> Moreover, the from= and to= attributes explicitly refer to that which
> is indicated by the type= attribute as a 'unit' ... so shouldn't the
> type= attribute really be a unit= attribute?
>> the description of biblScope/@type reads "identifies the type of
>> information conveyed by the element, e.g. columns, pages, volume" -
>> so shouldn't "col" be added to the list of suggestd values?